We are pleased to inform you that the slowness some customers may have experienced with the CloudBees platform has been resolved.
All systems are now operating normally. We appreciate your patience and apologize for any inconvenience this may have caused.
Posted Jun 18, 2025 - 16:47 UTC
Identified
Current Status: We have identified the root cause of the issue causing slowness. Some short-term actions have been implemented to reduce impact to end users. Our team is currently reviewing and testing a code fix, which will be deployed as soon as it passes all quality checks.
Posted Jun 18, 2025 - 16:13 UTC
Investigating
Status Update - June 18, 2025 13:30 UTC
We are currently experiencing performance issues with our platform, which may result in slowness for some customers. Our team is actively investigating the cause and working to resolve the issue as quickly as possible.
Impact: Users may experience delays or slower response times when using our services.
Scope: This issue appears to affect multiple services across our platform.
Status: Our engineers are diligently working to identify and fix the root cause of the slowness.
We understand the importance of restoring full functionality and apologize for any inconvenience this may cause. We will provide an update on our progress in the next 30 minutes.
Thank you for your patience.
Posted Jun 18, 2025 - 13:56 UTC
This incident affected: Feature Management (Feature Management - Flag creation) and Authentication, Notifications, Metrics.