Runs page slow to load

Incident Report for CloudBees platform

Resolved

This incident has been resolved
Posted Feb 09, 2026 - 16:58 UTC

Investigating

Viewing recently run workflows is currently slow to load, workflow execution is not affected
Posted Feb 09, 2026 - 16:25 UTC