workflow triggers are slow

Incident Report for CloudBees platform

Resolved

the incident has been resolved
Posted Oct 24, 2025 - 14:00 UTC

Monitoring

we have successfully tested the fix and we are monitoring its implementation
Posted Oct 24, 2025 - 13:59 UTC

Identified

wee have identified the issue and are working on fix
Posted Oct 24, 2025 - 13:58 UTC

Investigating

we are currently investigating an issue with workflows being slow to trigger.
Posted Oct 24, 2025 - 12:18 UTC
This incident affected: Workflow Execution.