Workflow runs are not viewable

Incident Report for CloudBees platform

Resolved

This incident has been resolved.
Posted Feb 06, 2026 - 21:18 UTC

Investigating

Workflows are running as expected but the runs page used to view recent workflows is experiencing slowness and timeouts. We are looking in to the slow response times.
Posted Feb 06, 2026 - 17:50 UTC