Investigating workflow runs not displaying in UI

Incident Report for CloudBees platform

Resolved

This incident has been resolved. The workflows that executed during this window did run, but their history is lost.
Posted Oct 21, 2025 - 17:05 UTC

Investigating

We are seeing that some workflow runs are not being displayed in the UI. Workflows are executing, but the results are not being displayed.
Posted Oct 21, 2025 - 16:29 UTC
This incident affected: Workflow Execution.