Following the deployment of the fix on Saturday, system performance was closely monitored for a full 24-hour weekday period.
Confidence has been reached that the underlying issue has been resolved, and workflow execution is stable and operating at normal performance levels.
This concludes communications regarding the workflow execution delay. Thank you again for the patience.
Posted Nov 11, 2025 - 14:54 UTC
Monitoring
The root cause was identified and a fix was applied on Saturday; processing has returned to normal. Performance will be monitored for the next 24 hours to confirm stability under load, but the issue is considered resolved. Thank you for your patience.
Posted Nov 10, 2025 - 16:41 UTC
Update
The engineering team continues to investigate the delayed workflow execution. Progress has been made in reducing the impact, and most users will experience significantly shorter delays. Active work on further improvements is underway.
Posted Nov 07, 2025 - 19:02 UTC
Investigating
We are investigating a delay in workflow execution.